User Tools

Site Tools


multichax_compatibility_list

MultiCHAX Compatibility List

NOTE: Windows OS 7, 8, 8.1 and 10 are supported. Mac OSX is not supported.

The software listed below are just some of the compatible products for MultiCHAX. Please contact us to see if your accounting software is compatible with MultiCHAX.

multichax_compatibility_list.txt · Last modified: 2017/05/23 09:23 (external edit)